// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(?:(?:INSERT <extra_id_[0-9]+>\s*(?://|#) \[\*\] \[LINE_COMMENT\] (.+?)\n|DELETE))").unwrap();
let string = "INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices
INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}