re = /(?:(?:INSERT <extra_id_[0-9]+>\s*(?:\/\/|#) \[\*\] \[LINE_COMMENT\] (.+?)\n|DELETE))/
str = 'INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices
INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end