package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(?:(?:INSERT <extra_id_[0-9]+>\s*(?://|#) \[\*\] \[LINE_COMMENT\] (.+?)\n|DELETE))`)
var str = `INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices
INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}