$re = '/(?:(?:INSERT <extra_id_[0-9]+>\s*(?://|#) \[\*\] \[LINE_COMMENT\] (.+?)\n|DELETE))/s';
$str = 'INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices
INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);