import re
regex = re.compile(r"(?:(?:INSERT <extra_id_[0-9]+>\s*(?://|#) \[\*\] \[LINE_COMMENT\] (.+?)\n|DELETE))", flags=re.DOTALL)
test_str = ("INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices\n"
"INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")