#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Za-z]{4}\d{7})|(\d{9})|(\d{8})"
Local $sString = "12345678" & @CRLF & _
"87654321" & @CRLF & _
"77777777" & @CRLF & _
"CAXA1234564 123456789," & @CRLF & _
"0123456789" & @CRLF & _
"AAAA12345678" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")