re = /([A-Za-z]{4}\d{7})|(\d{9})|(\d{8})/m
str = '12345678
87654321
77777777
CAXA1234564 123456789,
0123456789
AAAA12345678
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end