package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Za-z]{4}\d{7})|(\d{9})|(\d{8})`)
var str = `12345678
87654321
77777777
CAXA1234564 123456789,
0123456789
AAAA12345678
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}