import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-z]{4}\\d{7})|(\\d{9})|(\\d{8})";
final String string = "12345678\n"
+ "87654321\n"
+ "77777777\n"
+ "CAXA1234564 123456789,\n"
+ "0123456789\n"
+ "AAAA12345678\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}