$re = '/([A-Za-z]{4}\d{7})|(\d{9})|(\d{8})/m';
$str = '12345678
87654321
77777777
CAXA1234564 123456789,
0123456789
AAAA12345678
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);