using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Za-z]{4}\d{7})|(\d{9})|(\d{8})";
string input = @"12345678
87654321
77777777
CAXA1234564 123456789,
0123456789
AAAA12345678
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}