const regex = /([A-Za-z]{4}\d{7})|(\d{9})|(\d{8})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Za-z]{4}\\d{7})|(\\d{9})|(\\d{8})', 'gm')
const str = `12345678
87654321
77777777
CAXA1234564 123456789,
0123456789
AAAA12345678
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}