#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+)\s*:\s*((?:(?!\s*\w+\s*:).)*)"
Local $sString = "field1 : value1a value1b" & @CRLF & _
"" & @CRLF & _
"field1 : value1a value1b field2 : value2a value2b" & @CRLF & _
"" & @CRLF & _
"field1 : value1a field2 : value2a value2b field3 : value3a value3b value3c"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")