using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\s*:\s*((?:(?!\s*\w+\s*:).)*)";
string input = @"field1 : value1a value1b
field1 : value1a value1b field2 : value2a value2b
field1 : value1a field2 : value2a value2b field3 : value3a value3b value3c";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}