use strict;
my $str = 'field1 : value1a value1b
field1 : value1a value1b field2 : value2a value2b
field1 : value1a field2 : value2a value2b field3 : value3a value3b value3c';
my $regex = qr/(\w+)\s*:\s*((?:(?!\s*\w+\s*:).)*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}