import re
regex = re.compile(r"(\w+)\s*:\s*((?:(?!\s*\w+\s*:).)*)", flags=re.MULTILINE)
test_str = ("field1 : value1a value1b\n\n"
"field1 : value1a value1b field2 : value2a value2b\n\n"
"field1 : value1a field2 : value2a value2b field3 : value3a value3b value3c")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")