#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(Site:\h\d+\.\d+)?(.+?)(?:\h(P.*))?$"
Local $sString = "Site: 4442.001 Rental Charge (x 1) PU094928" & @CRLF & _
"Exchange1 x 6m Marrell - Construction &" & @CRLF & _
"Emptying of bin1 x 240L - Commercial & PU094928" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")