package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(Site:\h\d+\.\d+)?(.+?)(?:\h(P.*))?$`)
var str = `Site: 4442.001 Rental Charge (x 1) PU094928
Exchange1 x 6m Marrell - Construction &
Emptying of bin1 x 240L - Commercial & PU094928
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}