use strict;
my $str = 'Site: 4442.001 Rental Charge (x 1) PU094928
Exchange1 x 6m Marrell - Construction &
Emptying of bin1 x 240L - Commercial & PU094928
';
my $regex = qr/^(Site:\h\d+\.\d+)?(.+?)(?:\h(P.*))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}