// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(Site:\h\d+\.\d+)?(.+?)(?:\h(P.*))?$").unwrap();
let string = "Site: 4442.001 Rental Charge (x 1) PU094928
Exchange1 x 6m Marrell - Construction &
Emptying of bin1 x 240L - Commercial & PU094928
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}