import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(Site:\\h\\d+\\.\\d+)?(.+?)(?:\\h(P.*))?$";
final String string = "Site: 4442.001 Rental Charge (x 1) PU094928\n"
+ "Exchange1 x 6m Marrell - Construction &\n"
+ "Emptying of bin1 x 240L - Commercial & PU094928\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}