using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(Site:\h\d+\.\d+)?(.+?)(?:\h(P.*))?$";
string input = @"Site: 4442.001 Rental Charge (x 1) PU094928
Exchange1 x 6m Marrell - Construction &
Emptying of bin1 x 240L - Commercial & PU094928
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}