$re = '/^(Site:\h\d+\.\d+)?(.+?)(?:\h(P.*))?$/m';
$str = 'Site: 4442.001 Rental Charge (x 1) PU094928
Exchange1 x 6m Marrell - Construction &
Emptying of bin1 x 240L - Commercial & PU094928
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);