using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"import(?:[\s.*]([\w*{}\n\r\t, ]+)[\s*]from)\s+['""]lodash['""];";
string input = @"import {
groupBy,
get,
uniqBy,
concat,
differenceWith,
isEmpty,
intersectionWith,
} from 'lodash';
import { values } from 'lodash';
import { upperFirst, isEmpty, get } from 'lodash';
import { uniqueId, orderBy, isEmpty, uniq, uniqBy, groupBy, reduce } from 'lodash';
import _, { isNaN } from 'lodash';
import _ from 'lodash';";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}