import Foundation
let pattern = #"import(?:[\s.*]([\w*{}\n\r\t, ]+)[\s*]from)\s+['"]lodash['"];"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
import {
groupBy,
get,
uniqBy,
concat,
differenceWith,
isEmpty,
intersectionWith,
} from 'lodash';
import { values } from 'lodash';
import { upperFirst, isEmpty, get } from 'lodash';
import { uniqueId, orderBy, isEmpty, uniq, uniqBy, groupBy, reduce } from 'lodash';
import _, { isNaN } from 'lodash';
import _ from 'lodash';
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)