use strict;
my $str = 'import {
groupBy,
get,
uniqBy,
concat,
differenceWith,
isEmpty,
intersectionWith,
} from \'lodash\';
import { values } from \'lodash\';
import { upperFirst, isEmpty, get } from \'lodash\';
import { uniqueId, orderBy, isEmpty, uniq, uniqBy, groupBy, reduce } from \'lodash\';
import _, { isNaN } from \'lodash\';
import _ from \'lodash\';';
my $regex = qr/import(?:[\s.*]([\w*{}\n\r\t, ]+)[\s*]from)\s+['"]lodash['"];/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}