import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "import(?:[\\s.*]([\\w*\\{\\}\\n\\r\\t, ]+)[\\s*]from)\\s+['\"]lodash['\"];";
final String string = "import {\n"
+ " groupBy,\n"
+ " get,\n"
+ " uniqBy,\n"
+ " concat,\n"
+ " differenceWith,\n"
+ " isEmpty,\n"
+ " intersectionWith,\n"
+ "} from 'lodash';\n"
+ "import { values } from 'lodash';\n"
+ "import { upperFirst, isEmpty, get } from 'lodash';\n"
+ "import { uniqueId, orderBy, isEmpty, uniq, uniqBy, groupBy, reduce } from 'lodash';\n"
+ "import _, { isNaN } from 'lodash';\n"
+ "import _ from 'lodash';";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}