package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`import(?:[\s.*]([\w*{}\n\r\t, ]+)[\s*]from)\s+['"]lodash['"];`)
var str = `import {
groupBy,
get,
uniqBy,
concat,
differenceWith,
isEmpty,
intersectionWith,
} from 'lodash';
import { values } from 'lodash';
import { upperFirst, isEmpty, get } from 'lodash';
import { uniqueId, orderBy, isEmpty, uniq, uniqBy, groupBy, reduce } from 'lodash';
import _, { isNaN } from 'lodash';
import _ from 'lodash';`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}