const regex = /import(?:[\s.*]([\w*{}\n\r\t, ]+)[\s*]from)\s+['"]lodash['"];/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('import(?:[\\s.*]([\\w*{}\\n\\r\\t, ]+)[\\s*]from)\\s+[\'"]lodash[\'"];', 'g')
const str = `import {
groupBy,
get,
uniqBy,
concat,
differenceWith,
isEmpty,
intersectionWith,
} from 'lodash';
import { values } from 'lodash';
import { upperFirst, isEmpty, get } from 'lodash';
import { uniqueId, orderBy, isEmpty, uniq, uniqBy, groupBy, reduce } from 'lodash';
import _, { isNaN } from 'lodash';
import _ from 'lodash';`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}