# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=(?:\B\d{3})+$)/$/mg;t' <<< "2222
333333
12345
111
123456789
12345678"