import Foundation
let pattern = #"(?=(?:\B\d{3})+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2222
333333
12345
111
123456789
12345678
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)