use strict;
my $str = '2222
333333
12345
111
123456789
12345678';
my $regex = qr/(?=(?:\B\d{3})+$)/mp;
my $subst = '$';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";