import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(?:\\B\\d{3})+$)";
final String string = "2222\n"
+ "333333\n"
+ "12345\n"
+ "111\n"
+ "123456789\n"
+ "12345678";
final String subst = "$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}