const regex = /(?=(?:\B\d{3})+$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(?:\\B\\d{3})+$)', 'mg')
const str = `2222
333333
12345
111
123456789
12345678`;
const subst = `$`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);