$re = '/(?=(?:\B\d{3})+$)/m';
$str = '2222
333333
12345
111
123456789
12345678';
$subst = "$";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;