#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=(?:\B\d{3})+$)"
Local $sString = "2222" & @CRLF & _
"333333" & @CRLF & _
"12345" & @CRLF & _
"111" & @CRLF & _
"123456789" & @CRLF & _
"12345678"
Local $sSubst = "$"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)