#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![a-zA-Z0-9+\/]{44}).*$"
Local $sString = "AXm5MvpYPN4ETQCVIj2zGtckkDu5ssBpmrqbbAI48LdA" & @CRLF & _
"AVhySVqh4huj9rk54a4sXLA2PhqFau5m+GfZrRLp+vJ9" & @CRLF & _
"asd" & @CRLF & _
"this is a test" & @CRLF & _
"Anothersecond2+test" & @CRLF & _
"and Thats another one"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")