import Foundation
let pattern = #"^(?![a-zA-Z0-9+\/]{44}).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AXm5MvpYPN4ETQCVIj2zGtckkDu5ssBpmrqbbAI48LdA
AVhySVqh4huj9rk54a4sXLA2PhqFau5m+GfZrRLp+vJ9
asd
this is a test
Anothersecond2+test
and Thats another one
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)