use strict;
my $str = 'AXm5MvpYPN4ETQCVIj2zGtckkDu5ssBpmrqbbAI48LdA
AVhySVqh4huj9rk54a4sXLA2PhqFau5m+GfZrRLp+vJ9
asd
this is a test
Anothersecond2+test
and Thats another one';
my $regex = qr/^(?![a-zA-Z0-9+\/]{44}).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}