re = /^(?![a-zA-Z0-9+\/]{44}).*$/m
str = 'AXm5MvpYPN4ETQCVIj2zGtckkDu5ssBpmrqbbAI48LdA
AVhySVqh4huj9rk54a4sXLA2PhqFau5m+GfZrRLp+vJ9
asd
this is a test
Anothersecond2+test
and Thats another one'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end