const regex = new RegExp('^(?![a-zA-Z0-9+\\/]{44}).*$', 'gm')
const str = `AXm5MvpYPN4ETQCVIj2zGtckkDu5ssBpmrqbbAI48LdA
AVhySVqh4huj9rk54a4sXLA2PhqFau5m+GfZrRLp+vJ9
asd
this is a test
Anothersecond2+test
and Thats another one`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}