import re
regex = re.compile(r"^(?![a-zA-Z0-9+\/]{44}).*$", flags=re.MULTILINE)
test_str = ("AXm5MvpYPN4ETQCVIj2zGtckkDu5ssBpmrqbbAI48LdA\n"
"AVhySVqh4huj9rk54a4sXLA2PhqFau5m+GfZrRLp+vJ9\n"
"asd\n"
"this is a test\n"
"Anothersecond2+test\n"
"and Thats another one")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")