using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![a-zA-Z0-9+\/]{44}).*$";
string input = @"AXm5MvpYPN4ETQCVIj2zGtckkDu5ssBpmrqbbAI48LdA
AVhySVqh4huj9rk54a4sXLA2PhqFau5m+GfZrRLp+vJ9
asd
this is a test
Anothersecond2+test
and Thats another one";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}