# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*version=(\S+).*/\1/g;t' <<< " new\nmessage version=1.23 "