use strict;
my $str = ' new\\nmessage version=1.23 ';
my $regex = qr/.*version=(\S+).*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";