const regex = /.*version=(\S+).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*version=(\\S+).*', 'g')
const str = ` new\\nmessage version=1.23 `;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);