import Foundation
let pattern = #".*version=(\S+).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" new\nmessage version=1.23 "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)