#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*version=(\S+).*"
Local $sString = " new\nmessage version=1.23 "
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)