re = /.*version=(\S+).*/
str = ' new\\nmessage version=1.23 '
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result