$re = '/.*version=(\S+).*/';
$str = ' new\\nmessage version=1.23 ';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;